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1. Exchange Granular Restore overview 
The Exchange Granular Restore (EGR) console allows you to preview and then restore mail items from 
System Protection, File Protection and File Archiving backups. This means the same backup you use to 
protect your Exchange Server can be used to restore individual mail items.  

Exchange Granular Restore is the recommended tool for restoring mailboxes and mail items for Exchange 2013, 
2010 and 2007. It is enabled in BackupAssist when you purchase the Exchange Granular Restore Add-on and 
supersedes the Exchange Mailbox Protection solution. This earlier technology was purchased as the Exchange 
Mailbox Add-on, and is now bundled with the Exchange Granular Restore Add-on. Both solutions are supported. 

Exchange add-on comparison  

Feature Exchange Mailbox Add-on Exchange Granular Restore 
Add-on 

Exchange version support 2003, 2007, 2010 2007, 2010, 2013 

Exchange Server authentication Required Not required 

Special backup type Required Not required 

Mail Preview (before restore)  No Yes 

Backup size  Requires additional PST file backup Part of Exchange Server backup 

Backup destination  Local disks only As supported by backup type 

EGR support for backup types - by server version 

Backups Windows 2003 Windows 2008 Windows 2012 

System Protection    

File Protection & File Archiving    

The Exchange Granular Restore Add-on can restore: 
 Mailboxes, mail folders and emails (cannot be encrypted) 
 Folders 
 File attachments 
 Contacts 
 Notes, Tasks and appointments  

Journals, emails attached in other emails and embedded email objects are currently not supported.  

Requirements 
 BackupAssist 7.2 or later must be installed on the Exchange Server.  
 Operating systems: Windows Server 2012, 2008 R1/R2, 2003. 
 RAM: 256-1024 MB, depends on mail store size and OS version 
 May require free space on disk 1.5x the size of mail data being processed. 

Exchange Granular Restore is tested for optimal performance up to the following dataset sizes. 
 Database size: 500 Gb / Mailbox size: 100 Gb  
 Number of messages in one mailbox - 100,000, in the database - 2,000,000. 
 Number of mailboxes in the database: 2,000   
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2. Creating an Exchange backup 
This section explains how to back up your Exchange Server using BackupAssist on Windows 
Server 2008, SBS 2008 and later operating systems. These backups are used by Exchange 
Granular Restore to restore mailboxes and individual mail items. 

 How to use Exchange Granular Restore is documented in Section 3. 

Launch BackupAssist and follow the steps outlined below: 

1. Select the Backup tab, and click Create a new backup Job 

2. Select System Protection, File Protection or File Archiving.  

If this is the first time you have created a backup job, you will be asked to provide a Backup user 
identity if one has not been defined. See the BackupAssist settings, whitepaper for guidance. 

The following instructions use System Protection to explain the Exchange VSS back up process.  

 
Figure 1: New backup job – backup type selection screen 

Instructions specific to each backup type, can be found in their respective whitepapers. 

Remember: It is important to maintain both daily and archive (historical) backups as part of your backup 
strategy. The backup type and destination selected will effect what options you have, and both should be 
considered when planning a schedule. To learn more, see the Backup tab whitepaper’s Manage section on 
scheduling  
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3. Selections: The selections screen is used to select the data and applications that you would like to 
back up. Any local Exchange Servers detected will be displayed here as application containers. 

You can select an entire VSS application or choose individual components. To back up your 
Exchange Server, select the Microsoft Exchange container. 

If your local Exchange Server is not listed in the Selections screen, try restarting Exchange and the 
VSS service and then click the Refresh button in BackupAssist. 

 
Figure 2: New backup job – Exchange Server VSS selection 

 For System Protection backups, VSS applications will be backed up as part of a Backup up the 
Entire System selection. In the example above, Back up selected items only, was chosen and the 
Exchange Server application container was selected.  

 For File Protection, File Archiving and System Protection backups, the top level Microsoft 
Exchange and Exchange Server application containers should be selected. 

4. Destination media: The destination screen is used to select the type of media that you want to 
back your data up to. This step’s name will change to the media type selected, when you click next. 

Select a device for your backup destination, and click Next.  

5. Schedule: This screen is used to select when and how you would like the backup job to run, and 
how long you would like the backup to be retained for. A selection of pre-configured schedules, 
called schemes, will be displayed. Select an appropriate scheme, and click Next. 

For more information about creating custom schedules, refer to the Backup tab whitepaper. 
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6. Set up destination: This screen is used to configure the location of the media selected in step 4.  

Configure your backup destination, and click Next. 

 Mail Server: If you have not configured an SMTP mail server for BackupAssist, you will be 
prompted to provide those details after the backup destination step has been completed. See the 
BackupAssist settings whitepaper for guidance.  

7. Notifications: Once a backup job has completed, BackupAssist can send an email to inform 
selected recipients of the result. This email notification can be enabled during the creation of a 
backup job, if the mail server has been configured.  

To enable email notifications: 

a. Select, Add an email report notification. 

b. Enter recipients into the Send reports to this email address field. 

c. Enter recipients into the Also send reports to this email address field. You can then select 
the condition under which the email should be sent, using the drop-down box. 

8. Prepare media: If you selected a portable media device as your backup destination (such as an 
external HDD or a RDX drive) you will be given the option to prepare the media for BackupAssist. 
BackupAssist will write a label onto the media so that it can recognise what media has been 
attached, and determine if it is the correct media for your backup schedule.  

To enable media detection: 

a. Select, Let BackupAssist keep track of your media. 

b. Select what you would like BackupAssist to do, if the wrong media is inserted. 

c. Select what you would like BackupAssist to do, if new or unrecognized media is inserted. 

BackupAssist will display all removable media that are currently attached, along with a text field 
and drive designation drop-down box, which can be used to provide a label for the media. 

To prepare your media: 

d. Enter the name and drive designation to be used for each media device listed. 

e. Select Prepare for each media device listed. 

BackupAssist will now write the label to the media so that it is able to recognize the media and 
ensure that the correct media is being used on the correct day. For example, if you put an RDX 
drive in on Tuesday but it was labeled Wednesday, BackupAssist will warn you that the incorrect 
media has been detected.  

9. Name your backup: Provide a name for your backup job, and click Finish.  

Your Exchange Server (VSS) backup job has now been created. 

Important: Once a backup job has been created, it should be reviewed and run using the Manage 
menu. This menu provides additional options to configure your backup.  

Important: Once a backup job has been run and a backup created, a MANUAL test restore should be 
performed to ensure the backup is working as intended. To perform a test restore, refer to the section, 
Restoring Exchange Server backups.  
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3. Exchange Granular Restore 
Exchange Granular Restore (EGR) is enabled with the purchase of the Exchange Granular 
Restore Add-on. This restore-based solution allows you to use System Protection, File 
Protection and File Archiving backups to restore individual mailboxes and mail items.  

Note: To restore mail items from within a Hyper-V guest, you will need to mount the image backup using the 
Hyper-V Granular Restore console first. Then you can use EGR (launched from the Tools menu) to access the 
EBD file, from within the mounted image. 

Note: Exchange Mailbox Protection backups cannot be restored using this process. They are part of the 
Exchange Mailbox Add-on, and are restored by selecting the Mailbox Protection Restore option in step 4 below.  

To restore individual mail items, follow the steps below: 

Step 1 - Locate the Exchange backup 
a) Start BackupAssist and select the Restore tab 

The Restore tab has a Home page and a Tools menu. The Home page is the default screen and the 
recommended starting point for performing a restore. The Tools menu should only be used by 
experienced administrators or users being assisted by technical support.  

b) From the Restore Home page, select Exchange 

 
Figure 3: Restore tab - Home page 

This will open the Restore > Exchange screen and display the restore options available. 
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c) From the Restore > Exchange screen, select Exchange Granular Restore (.edb) 

 
Figure 4: Restore Exchange page - selection screen 

Backups made with BackupAssist 7.1 and later, that contain Exchange databases, will be displayed.  

d) Select the database file to restore from 

 The backups displayed can be filtered using the time period tabs.  
 Selecting a backup will expand its contents and display each .edb database inside the backup. 

When you select the required database file, the Exchange Granular Restore console will start and 
open the .edb file. A progress window will appear while the database is opening. 

 
Figure 5: Exchange Restore - backup and database selection 

Once the .edb file has been opened, you will be able to view the mail items inside it. 
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Step 2 - Locate and mail items 
The Exchange Granular Restore (EGR) console has a Browse mail tree and a Search field to help locate, 
preview and select the mail items that you want to restore.  

If you open EGR from the Restore > Tools menu, you can open a database using the Open Exchange DB button. 

Console options 
Both the Browse and Search functions can use the following options. 

 Display filter: Press CTL+F and a Filter field will appear under the list of currently displayed mail 
items. Select the Subject, From, To, Attachments, Created or All filter, and enter the text to filter by. 

 Restore Deleted items: Display hidden deleted items, is available in the Options menu, and 
selecting it will give access to previously deleted mail items. This is not mail from the delete items 
folder but mail items that are no longer present. The database will reload when a selection is made 
and the deleted items will and have a flag to indicate that they are a deleted item. 

 Deleted items from Exchange Server 2007 are stored in their original folders. 
 Deleted items from Exchange 2010 and 2013 are stored in the folder Deletions. These items 

cannot be restored to live Exchange Server database. It is recommended that these items are 
exported to a PST file and then imported into the live Exchange Server. 

 Display time: Select Display time, from the Options menu and select Local or GMT. This applies to 
the date in the properties tab of a mail item. The database will reload when the format is changed.  

Using Browse 
The Browse mail tree is displayed in the console’s left pane. Browsing for the items you want to restore 
is ideal when you know their location.  

 
Figure 6: The Exchange Granular Restore console 

 Selecting a folder will display the individual mail items inside it, on the pane to the right.  
 Selecting a mail item will preview its contents in the pane below it.  
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Using Search 

The Search field is ideal when the location of a mail item or the number of items to restore is 
unknown. When a keyword search is performed, a new tab with a browse tree will open containing 
only the mailboxes, folders and mail items that match your search criteria.  

The search word must be a whole word. 

To perform a simple Search, enter the search word into the field, click the search icon and the Search 
tab will open in the console. This Search tab will contain all items in the database that contains the 
word you entered. 

To perform an advanced Search, select the arrow by the Search field to display the advanced search 
options. The Search in field will default to the entire database. To search inside specific mailboxes or 
folders, select the Search in field and use the dialogue window to select the required containers. 

The following search options are available: 

 Has words, searches for mail items that have words or phrases entered into the field.  
 Doesn't have, searches for items that do not have words or phrases entered into the field.  
 Has attachments, will search for items with attachments.  
 From, will search for keywords in the From: field.  
 To, will search for keywords in the To: field.  
 Subject, will search for keywords in the Subject: field.  
 Date range, can be used to set a specific date range. A beginning and end dates must be set.  

 
Figure 7: Exchange Granular Restore console - Search tab 

If a search does not match any items, review your search parameters and run another search.  

Once you have located the mail items that you want to restore, select them using the tick box. Once 
you have selected an item to restore, the restore type icons in the menu will become active. 
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Indexing Modes  

Database indexing can be disabled or cancelled via the Options menu. If indexing is disabled, a 
database search will not be possible. Two indexing modes are supported: Light and Full.  

 Light indexing (default): Limits the searchable information to the following fields: From, To, Subject, 
Date range. A To field with a long recipients list and message bodies will not be indexed.  

 Full indexing: This mode will take longer to index as it allows a search across the entire database. 

Step 3 - Perform the restore 
Once you have located the required mail items, there are three ways they can be restored using the 
Exchange Granular Restore console: Export to PST, Restore to original location and Restore to alternate 
location. Each of these options is explained below. 

Option 1: Restore to original location 

This option will restore the selected mail items back into their respective mailboxes on the 
original Exchange Server.  

To perform the restore, follow the steps below: 

a) Select the Restore to original location button. 

An Exchange Server connection window will open. The domain name of the server running 
Exchange will be automatically detected if you are on the same domain.  

b) If no Exchange Server is detected, fill in the field Server name manually and click Reconnect. 

It is possible to restore data to someone else’s mailbox using Exchange Impersonation. To do this, 
the current user credentials must have Exchange Impersonation access to destination mailboxes. 

 

c) Select Restore, to begin the restore process. 

The time required will depend on how many items were selected, and a progress window will be 
displayed during the restore. The window shows the number of saved folders, messages and 
errors. You can enable and disable the progress window in the Options menu. 

 The restore can be cancelled by clicking the Cancel restore button. 
 The progress window can be reopened by clicking Progress bar on the status panel. 
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Option 2: Restore to alternate location 

This option will restore the selected mail items to a different Exchange Server and / or 
mailbox. This injection capability will restore the emails and mail items from the offline 
backup to a live Exchange database that is different to the one they were backed up from. 

To perform the restore, follow the steps below: 

a) Select the Connect to Exchange Mailbox button. 

The Connect to Exchange Mailbox button will open the connection dialog box, which is used to 
provide the Exchange Server name and the authentication details (User logon) for a specific 
mailbox on that server. This authentication process can be repeated for additional mailboxes.  

The Restore to alternate location button will become active when a connection has been made. 

 
Figure 8: Restore to alternate location – connection authentication 

Enter the following details into the connection dialog box: 

 Server name - Domain name Exchange Server or IP address 
 Mailbox user name - This will identify, authenticate and open the applicable mailbox. 
 Password- The password for the applicable mailbox. 

If Use current Windows credentials is selected, the existing user’s Windows password will be used. 

If Exchange Impersonation is selected, enter the SMTP address of the mailbox that you want to 
connect to. Exchange impersonation must also be configured on the Exchange Server. 

Once the connection has been made, the mailbox you have authenticated to will appear as a 
mailbox tree in a new pane called Connected Mailboxes. You can open a preview pane for the 
destination mailbox tree by selecting the Show item list and preview icon (CTL+R), to the right of 
the Connected Mailboxes pane.  

b) Restore mail items to an alternate location 

There are two ways to restore mail items to the alternate location: drag and drop and the Restore 
to alternate location button.  
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Drag and drop 
Drag and drop mail items from the EDB database backup (either Browse or Search tab), into the 
live Exchange mailbox that you connect to (Connected Mailboxes tab).  

 The hierarchy of the data being dragged will be recreated inside the destination folder.  
 You can create a new folder in the live mailbox by right clicking the mailbox or a folder. 

 

Restore to alternate location button  

Click the check-box next to items that you want to restore and select the Restore to alternate 
location button. A dialog box will open and allow you to select a destination folder on one of the 
connected mailboxes. Make your destination selection and select OK to begin the restore 

 The data hierarchy will be restored automatically.  
 The root of hierarchy is the closest common parent item. 

Source mail items and destination folder compatibility 

Not all types of mail items can be restore to all types of destinations folders. The following table 
shows the compatibility matrix of source mail item types and destination directories. 

Item type *Mail folder Journals Notes Contacts Calendar Tasks 

Message Y Y Y Y Y Y

Journal Y Y Y Y Y Y

Sticky Note Y Y Y Y Y Y 

Contact N N N Y N N 

Calendar N N N N Y N

Task N N N N N Y 

* The Mail folder includes Deleted Items, Drafts, Inbox, Junk, Outbox and Sent.  

If some or all of the selected items cannot be restored (using drag and drop or clicking the Restore 
to alternate location button) to the destination folder, then an error message will be displayed. 
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Option 3: Export to PST 

Export to PST will save your selected data in a PST file. 

To perform the export, follow the steps below: 

a) Confirm the Personal Storage Table (PST) format  

You can choose Unicode or ANSI encoding for the PST output file using the Options menu.  

The Exchange Granular Restore console exports each mailbox into a separate .pst file named: 
“Restore NNN <Mailbox Name>[ VVV]. pst”, where NNN is the current recovery session identifier 
and VVV is the volume number, in case the PST file has to be written in more than one volume.  

With large exports, there can be more than one PST file. Additional files are created automatically 
when the file size limit is reached. The size limit depends on the output file encoding.  

 For ANSI PST files, the size limit is 1 GB. 
 For Unicode PST files, the size limit is 10 GB.  
 A maximum of 15,000 messages can be restored into the PST file.  
 When this limit is reached, an additional PST file is created.  

b) Select the , Export to PST button 

Once the mail items have been selected, they need to be exported from the database file. To 
export the selected mail items, click the Export button on the toolbar. 

c) Select the destination. 

You will be asked to select or create a destination folder. After selecting a folder, the export will 
start. The time required for the export will depend on the number of mail items.  

You will be shown a progress window during the export. The window shows the number of saved 
mailboxes, folders and messages. The export can be cancelled by clicking the Stop Export button. If 
you close the progress window, it can be opened again by clicking the status panel‘s progress bar. 

 

The items selected (even if you only selected one item) will be exported as a PST file. 
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d) Open the exported mail items in Outlook. 

1. Click File > Open and choose Open Outlook Data File.  

2. Browse to the PST file that was exported, then select it and click OK.  

3. The PST file will appear in Outlook as a container. 

 
Figure 9: Opening an exported PST file in outlook 

e) Restore the exported items to the Exchange Server.  

Items extracted from an offline Exchange mail store can be restored to a live server. Make sure you 
have Microsoft Outlook and access to the mailbox that you want to restore the mail items into.  

1. Open the PST file that contains the exported mail items. 
2. Open the mailbox that you need to import the data into.  
3. Select the items, and drag-and-drop them back into their original folders. They will be 

automatically synchronized with the live Exchange Server database.  

 
Figure 10: Restoring a PST file to an Exchange Server. 


